Running CRY Example Using Geant4 Interface

Geant4 Version: 11.1.2
Operating System: Ubuntu 23.04
Compiler/Version: GNU Make 4.3
CMake Version: CMake 3.25.1
Hardware: Oracle VirtualBox
CRY Version: 1.7

Dear all:

I was able to compile the example file for CRY using the Geant4 interface. However, when I tried to execute the following:

/run/beamOn 100

I get this error:

Idle> /CRY/update
CRY::CRYData: Error reading ../data/  Stopping
cosmic: CRYData::CRYData(std::string): Assertion `0' failed.
Aborted (core dumped)

Additonally, when I enter /run/beamOn 100 this happens:

*** G4Exception : had001
      issued by : G4CrossSectionDataStore::BuildPhysicsTable
No cross section is registered for neutron

*** Fatal Exception *** core dump ***
 **** Track information is not available at this moment
 **** Step information is not available at this moment

Attached here are the copy of the cc files and the CMakeLists file that I used: (3.5 KB)
CMakeLists.txt (2.4 KB) (7.8 KB) (5.1 KB) (3.6 KB) (4.1 KB) (220 Bytes)

I tried my best to replace the Physics List headers and update the methods. Kindly help me identify the missteps that I have taken.

Thank you very much!



As CRY is a third party application, you should contact the CRY developers through their mailing list or any other channel(s) they provide for best assitance.