Setting nuclear de-excitation half lives in v10.03.p02

Geant4 Version: 10.03.p02
Operating System: Linux centos7
Compiler/Version: gcc version 8.2.0
CMake Version: 1.3.0

I am using a custom PhotoEvaporation file to simulate the decay of Cs136 from its excited 588.8 keV state. The photon evaporation file is attached. Geant can successfully simulate the level energies and the internal conversion, but it appears that all half-lives are set to 0 when running the simulation. That is, each excited state of Cs136 seems to decay immediately, instead of having the O(100 ns) half-lives expected.

What I am finding is that no matter what data file I use, for whatever isotope, it seems that I cannot change the half-lives from their pre-defined values in the original photon evaporation data directory:

This issue is not resolved by using the macro command /grdm/setPhotoEvaporationFile <Z> <A> <local/directory>, nor is it resolved by setting G4LEVELGAMMADATA to the correct local directory. This does enable Geant to simulate the correct level structure (i.e. energies of the excited states, as well as the decay energies of the resulting gammas/IC electron), but it does not appear to help in properly simulating the half-lives.

I am using the QGSP_BIC_HP physics list, and adding G4RadioactiveDecayPhysics. From this post, it seems that the physics list may be the source of the issue, but I am doubtful that this is the case because Geant successfully creates the isomers, just not with the correct half-lives.

Terminal output also shows that there is a high time-limit for long lived isomers:

======       Pre-compound/De-excitation Physics Parameters     ========
Type of pre-compound inverse x-section              3
Type of de-excitation inverse x-section             3
Min excitation energy (keV)                         0.01
Level density (1/MeV)                               0.1
Time limit for long lived isomeres (ns)             1e+12
Use new data files                                  1
Use complete data files                             1
Correlated gamma emission flag                      0
Number of de-excitation channels                    8

Are there any insights into how to resolve this issue?
PhotonEvap.z55.a136.txt (1.2 KB)

v10.3 is very old. Does the issue also occur in more recent versions?

Thanks for the reply! I downloaded v11.2.1 and seem to be having the same issue. I get that 10.3 is old, but that is the version used by my experiment and is the basis of our simulations.

Thanks for the info! I’ll leave it to the physics experts to follow up here.


in 11.2.1 the limit on decay time is set to 1 ns. This means that radioactive isomers, which have lifetime below 1 ns, will decay promptly and time shift will not be taken into account. If lifetime above 1 ns, then the isomer will be produced as a G4Track, will travel, has ionisation energy loss, and decay at different point.


Thank you! I think the best way to illustrate my issue is through the rdecay01 example in 11.2.1. If I run the No252.mac file, I get the appropriate mean life as listed in the terminal output. However, this mean life (3.52 s) does not change even when I edit the UserData/UserEvapData_z102.a252 file to increase the half-life of the ground state, the terminal still gives the same means life of 3.52 s. I seem unable to control the half-life of metastable states by editing the photon evaporation files. Do you have any insights here?