Why can't it be visualized?

Problem:


It have no error,but it can’t be visualized.
I’d like to know what cause this problem and how to solve it.
Thank you very much!

1 Like

I have not seen that before. Can you please tell us: what operating system (Window, Linux,…?) and its version, what version of Geant4, and what options - in particular, what graphics options - did you use for building (cmake)? Are you trying to run one of the examples distributed with Geant4 (which?), or your own application? Interactively or as a batch job (in which please attach the macro file you executed)? Also, please attach a more complete log of the output, particularly near startup, where it lists (usually) the available graphics systems. It would help if you specify “/control/verbose 2” either on the command line or in the macro, so that we can see what commands are being executed or attempted.

System: Ubuntu 20.04.3
Version: Geant4.10.07.p02
The enviroment variables are as follows:


I used the interactively with QT to vis my own geometry.
The vis.mac is:

# open the visulization driver
/vis/open OGL
# draw the volume
/vis/drawVolume
# have a nice view 
/vis/viewer/set/background  white

# fresh the view
/vis/viewer/set/autoRefresh true

# set the verbose of vis: errors and warnings
/vis/verbose warnings
 

Is it possible that my geometry is too complicated and my graphics card(P6000 tested) is not good enough?
Thank you!

1 Like

Mmmm. You have many G4 environment variable set. The only ones that are needed nowadays if you build with the CMake system (see Installation Guide) are those pointing to data. The others, I guess, are used by the GNUmakefile way of building, which I have not used for a long time, and is deprecated.

The user interface is sensitive to environment variables. For example, G4UI_USE_TCSH=1 forces a tcsh-like session in the terminal from which you started your app. And G4UI_USE_QT=1 would start a Qt GUI. It seems to me those environment variables are mutually exclusive - I don’t know what happens if you set both. Look at source/interfaces/basic/src/G4UIExecutive.cc - environment variables take precedence. See How to Set Up an Interactive Session — Book For Application Developers 10.7 documentation.

All the same, I do not understand why this should result in “Killed”. I recommend you remove all but the data environment variables and use the CMake way of building.

Do you mean you have been successful in this case? The vis.mac looks perfectly OK.

I doubt that would be a problem. You could try increasing the OpenGL display list limit - /vis/ogl/set/displayListLimit 9999999. You could try using “immediate mode” -/vis/open OGLI. Also, there have been problems when the graphics driver is not up to date - you would have to get the driver from the manufacturer of P6000.

Anyway, please let us know how you get on. Good luck.
John

1 Like

In addition to @allison’s comments above, have you tried building and running one of the basic examples? Assuming these run and visualise things o.k. that would confirm an issue with your application, if it shows that same error, it might indicate an issue with the graphics card driver.

1 Like

The basic examples are normal,so i am confused with the problem.

I used the /geometry/test/run and there is no error in my code.But, when i use the qt to vis, it will wait for a long time and then “killed” is displayed.