B1 example of Geant4 11- Impossible to find the entering point

Hello, I’ve just installed the new Geant4 11 (I still had Geant4 10.7)
During the Geant4 installation I didn’t get any error, but running the B1 example (both

to I get this error message

“Impossible to find the entering point ?UseBestUnit@G4SteppingVerbose@@SAXH@Z of proceudre in dynamic link library”.

What does it means?

@bmorgan maybe you know how to solve it.

EDIT I found and I commented, in exampleB1.cc the line

G4SteppingVerbose::UseBestUnit(precision);

but now, when I run I get the error

How is it possible that a G4 example doesn’t work?

i think that means that your environment variables are not set / not set correctly. did you check that after moving from 10.7 to 11 you also updated all necessary settings as described in the installation manual?
if you built the example B1 with 10.7, you probably cannot simply run it with 11 configures and vice versa, without rebuilding the example…

Hello @weller

I setted the environment variables

Here the bin and lib G4 paths

And here all the needed packeges

No…I’m talking about the B1 example of G4 11! I’m trying it!


get rid of that old 10.7 stuff that is higher in the list :slight_smile:

Thank you @weller ! you solved the problem…I deleted the environment variables of Geant 10.7 and now the B1 example of Geant4 11 works!

But, I’ve some simulations made by Geant4 10.7 then I need both Geant4 10.7 and Geant4 11…
Isn’t there a way to have both of them withou modifying the environment variables each time?

Maybe you or @bmorgan know how to have both the Geant4 versions??

You can’t have them both at the same time. The same set of envvars is used to point at information for the version of G4 you’re currently using. What you can do is write yourself a setup script where you specify the G4 version you want, and the script does the corresponding version setup. Then you can have one terminal open with your G4 10.7 environment, and another terminal open with your G4 11.