Cannot Visualize anything in

Geant4 Version: 11.2.1
Operating System: Garuda Linux KDE
CMake Version: 3.29.0

There are nothing loading in the graphics version, I’ve tried Ubuntu, Garuda GNOME and Garuda KDE as well as Arch Linux but nothing seems to solve this issue. I ticked OpenGL X11 and Use QT options in CMAKE GUI when compiling Geant4 from the source code. The Terminal shows no errors whatsoever and everything looks okay.

It may be due to interference between X11 installations and Qt installations. We have seen that. One has to be very careful. Try building without X11.

Also, see GEANT4 Visualization on MacOs.

I turned off X11 option and rebuilt it only ticking Data and Qt one. I still get the problem.

This shows problem with every tab I open, not only that specific one.


When you say “it” did you mean a complete rebuild of Geant4 libraries without X11, as well as your app? (You need to rebuild both.) Did you turn off all X11 options, including e.g., GEANT4_USE_RAYTRACER_X11?

Let us have a look at your build options.

Another possibility is that your graphics card driver needs updating?


I deleted all the geant4 directories and then did a complete rebuild. I only turned the Data and GEANT4 Qt build options. How can I check if my graphics card driver needs updating? Thank you.

Re graphics card, you just have to find out what graphics card you are using, then google for a driver.

Apart from that, I’m at a loss. Have a look at “Supported and Tested Platforms” in the Release Notes. We can’t possibly test all variants of operating systems and Garuda and Arch are not among them. Maybe someone out there has used them. I know many who use Ubuntu. Maybe KDE is the problem - can you try without?

i can check if glxgears program run correctly on you linux.
You must see running gears.

I tried Ubuntu as well, same issue. And glxgears is working.

Do you run you examples locally or accessing to the machine via ssh ?
Often this kind of problem arrived when you connect to the machine via ssh.

locally. from the /examples folder

Can you provide information about Ubuntu and Qt versions you are use
and how qt was installed ?

It was the LTS Edition of Ubuntu GNOME, Qt versions were installed using apt package manager.

My opinion, your problem not related to Geant4 directly.
To use default viewer (OpenGL) you need install vendor driver with opengl support
for you video card. Please, check the driver installation with you local IT personal.