Example B1 issue (Windows): Post Installation guide

Hello !

I’ve recently achieved to download and install on windows10 Geant4 10_06_p01 without errors.So I’m trying to run example B1 as mentionnend in the installation guide, but the following error occurs :

-------- WWWW ------- G4Exception-START -------- WWWW -------

*** ExceptionHandler is not defined ***
*** G4Exception : UI0002
issued by : G4UIExecutive::G4UIExecutive()
Specified session type is not build in your system,
or no session type is specified.
A fallback session type is used.
*** This is just a warning message. ***
-------- WWWW ------- G4Exception-END -------- WWWW -------

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : PART70000
issued by : G4NuclideTable
G4ENSDFSTATEDATA environment variable must be set
*** Fatal Exception *** core dump ***

I saw on the forum that *** core dump *** probleme could comes from environnement variables, so I followed the postinstall tutorial to add them to Path but it changed nothing (I’ve also reboot computer).

notes :I am using cmake 3.18.2, visual studio 2019 so everything should work properly right. Install and build apparently worked. I can also build example B1 with no problem. This issue appears when I run the executable generated by the example. I traced the issue to the post installation guide in this post, but I believe I did everything correctly in the post install guide for windows (Im probably wrong if not it would be working). Can someone please help me with the post-installation setup or if you ran into this same problem?

Thank you for reading me and for helping me !

In the session where you run the example, how is the environment setup in that session, i.e. the names and values of the environment variables?

Hello Mr. Morgan and thank you for your response,

In the Path user variable I have the direction: C:\Geant4\geant4_10_06-build\BuildProducts\Release\bin which is where I have all my dll files in the Geant4 build folder:

Although I did not ran the command: (GEANT4_INSTALL_DATA=ON), to download the data initially, I downloaded these files one by one from this site: https://geant4.web.cern.ch/support/download

I added the files to a folder with the directory: C:\Geant4\geant4_10_06-install\share\Geant4-10.6.2\data

And as instructed in the post-install guide in here: http://geant4-userdoc.web.cern.ch/geant4-userdoc/UsersGuides/InstallationGuide/html/postinstall.html

I added a user variable with the specific name in the above URL pointing towards the direction: C:\Geant4\geant4_10_06-install\share\Geant4-10.6.2\data where all these .tar data files are located.

When I run the B1 executable file after doing this I get the following error:

Thank you so much for helping me! Any more detailed information you may need to better understand my problem let me know, I am getting frustrated with getting stuck and not finding answers to this problem as I followed line by line the installation guide. Thank you so much again!


Thanks for the detailed info! I think all that’s missing is to untar each of the .tar files in the C:\Geant4\geant4_10_06-install\share\Geant4-10.6.2\data directory. If Windows can’t do this directly, cmake can do so by running (from the cmd prompt in the that directory), I think:

> cmake -E tar xf G4ABLA.3.1.tar.gz

and so on for the remainder. If your environment variables for the data are pointing the to directory names, e.g. G4ABLADATA is set to C:\Geant4\geant4_10_06-install\share\Geant4-10.6.2\data\G4ABLA3.1, then things should then work. If the variable values include the .tar or .tar.gz extension, simply remove them from the value.


I was finally able to run example 1 and build the geometry. However, I am having trouble with an error after running the beam:

The output I am getting is this one:

Idle> /control/verbose 2
/control/verbose 2
Idle> /tracking/verbose 1
/tracking/verbose 1
Idle> /run/beamOn 10
/run/beamOn 10

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : em0003
issued by : G4SeltzerBergerModel::ReadData()
Bremsstrahlung data file <C:\Geant4\geant4_10_06-install\share\Geant4-10.6.2\data\G4EMLOW7.9.1;/brem_SB/br6> is not opened!G4LEDATA version should be G4EMLOW6.23 or later.

*** Fatal Exception *** core dump ***
**** Track information is not available at this moment
**** Step information is not available at this moment

-------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution ***

Thank you for your help!

Just as an update, I was able to solve this issue by redifining all environment variables as stipulated in the post-install setup guide. Hope this helps someone later!