Facing issue with the OpenGL visualization software for GEANT4.



What exactly is the problem?

Hi,
I am unable to see any geometry after running the examples even though the simulation is successful. You can see in my previous uploaded photos (first one), it is blank.
you can also see my cmake configurantion settings.

Thank you.

Mmmm. I see. The Qt GUI window does look strange. Try making it bigger.

What version of Qt are you using? You may need to update to Qt 5.15 - but do not update to Qt6.

As a workaround try GEANT4_USE_QT=OFF and GEANT4_USE_OPENGL_X11=ON and rebuild (make clean, then cmake and make).

Thank you for your response!
I am using Qt 5.9.5.

If you have noticed, In cmake after configuration it is showing X11_xcb path do not found. is this possible reason? if yes how to correct this ?

I’m not sure it’s a problem. You are clearly building with X11 (GEANT4_USE_RAYTRACER_X11=ON). Try GEANT4_USE_OPENGL_X11=ON - it might build OK.

I tried `GEANT4_USE_OPENGL_X11=ON but it did build well. Still no Geometry.

Sorry,
Typo: it did not build well.

OK. It looks like it has built well, but not executed well.

You are still using Qt. Did you try without Qt:

Yes, I tried without Qt. It shows some error!

OK. It looks like you have some problem with X11, the windowing system that comes with Linux. What Linux variant are you using? Can you make sure it’s up to date with its version of X11? Are you (by any chance) using X11 (and Qt) over a network (i.e., Geant4 running on an remote machine)? In which case X11 needs to have GLX active (it says “Failed request: GLX”).

I am using Ubuntu 18.04. I will check and get back to you.

Thank you so much!

Hello, I’m facing the same error trying to install Geant4 in Windows 10, I have tried to enable the visualisation drivers but this pop ups:

Someone knows how to solve it?
Thanks a lot for the help

Hi @Guidepast, the error would suggest Qt5 isn’t installed on the system or that CMake is not able to locate it. If Qt5 is installed, then you’ll need to point CMake to it using the CMAKE_PREFIX_PATH variable. There’s information about that in our Installation Guide and in the CMake Documentation. Within the CMake GUI, it’s probably easiest to use the “Add Entry” button to add CMAKE_PREFIX_PATH with a value that is the path to where Qt5 is installed.

As this is a Windows install issue rather than a runtime Ubuntu issue as the original question, try the above, and if you still have issues please post this as a new question/thread. This is just so we don’t disrupt/mixup helping with the original poster’s question.

1 Like

Hi, problem is solved. I am getting the geometry now.

Thank you so much for your help!

Hi @mritunjay,
Can you please share how did you solved this?
I’m facing the same problem on a Fedora 34 system with Qt 5.15.2 and GEANT4_USE_QT=ON and GEANT4_USE_OPENGL_X11=ON.

Thank you.

Hi,
I had some issues with x11 package that comes with the Linux. I just reinstall it. The problem was solved.