Does not show any geometry and beam

I have the same situation this topic
Continuing the discussion from Facing issue with the OpenGL visualization software for GEANT4.:

I installed the geant4 v11.0.0 in Ubuntu (WSL2).
-DGEANT4_USE_OPENGL_X11=ON
-DGEANT4_USE_QT=ON
I build and compile examples/basic/B1. There are no errors.
Then I run ./exampleB1, Qt UI show via Xserver.
But no geometry in View.

I try /run/beamOn 1, then Qt UI dumps and Segmentation fault occurs.
log.txt (11.3 KB)

Other, I try -DGEANT4_USE_QT=OFF. UI show the geometry without beam but immediately dump.

Please advice.
Thanks.

Hi

In Facing issue with the OpenGL visualization software for GEANT4. - #7 by mritunjay the problem was solved by re-installing X11. Did you try that?

It’s also good to check that you have an up-to-date driver for your graphics card.

If you have built with

you should be able to

/vis/open OGLSX

which will open an X11 window outside the Qt GUI.

Let us know how you get on.

John

Thanks allison.

I tried to reinstall X11-apps, but the same situation.

I try

/vis/open OGLSX

I get a geometry on X11 window outside the Qt GUI.


But click on the X11 window, disappear the geometry in the X11 window.

I will try to check the driver of my graphics card.

I found the solution on WSL Ubuntu.

In WSL setting,

LIBGL_ALWAYS_INDIRECT=0 in /usr/share/wslu/wsl-integration.sh

In Windows Xserver(VcXsrv) setting,
Not use -wgl arguments(default is ON).

Good. Well done. Thank you for letting us all know.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.