Geant4 with Qt5 Installation on Redhat 8.x

Hello community,

I recognize that Centos 7 is the primary supported linux based system, but I am curious if users have had success or problems building and compiling on RHEL 8.

I noticed an issue here with visualization here described by @aantionio26 here which isn’t quite clear if the issue was resolved, or just the cause for the issue was found:

And an incomplete thread here for RHEL usage of OpenInventor

I appreciate your help to understand whether there are other RH users working successfully, before setting up the RH OS.


There’s nothing in those threads - or anywhere, as far as I’m aware - to suggest that Geant4 and all its visualisation drivers will not work on RHEL. The first thread was about visualising with X11 over a network (Geant4 running remotely) and, of course, X11 at each end has to be properly installed and configured. In the second, the user did not come back to us, so I assume he/she was happy.

Make sure X11 and OpenGL are installed according to RHEL instructions and all should be well. Follow the Geant4 Installation Guide to the letter. If you can get Geant4 up and running with the simple OpenGL X11, I recommend you try installing Qt (from and trying that - it has many additional features.


in my case, the problem was related to the sole availability of visuals with no stencil buffer. I solved the issue by setting GLX_STENCIL_SIZE to 0 in After that change, everything worked properly.


HI Antonio. Yes - but if I remember correctly, that applied to the version of X11 on the remote machine (because that is where Geant4 was running), but there is no suggestion there was any such limitation on the local machine. So there should be no such problem if Paul runs entirely on his local machine. Correct me if I’m wrong.

Hello John and Antonio, I’ve had success running G4 7 w/ Qt on windows and osx, so thanks, that will be my next step.

@aantonio26 That’s great to hear then that it solved the problem, I appreciate it.

@allison I too am looking to run a virtual machine in this work from home world we are in, so that was also why I wanted to clarify it worked. I suppose RHEL could go on the list of supported OS under pre-requisites.

Best regards,

Hi There,
I stumbled on this:;11d6001.1904

which might explain why there is lack of interest for the RHEL/CentOS 8 at CERN.

The developers might have a better idea of what is going on here.

One important note, the supported platform seems to be “CERN CentOS Linux 7 (CC7)” which is NOT CentOS 7.

I did not attempt to install G4 on CentOS 8 but I’d say it should be doable with some effort. Please let us know if you are successful.