Issues running Example B1

Hello !

I’ve recently achieved to download and install on windows10 Geant4 10_05_p01 in RelWithDebInfo config, without errors.

So I’m trying to run example B1 as mentionnend in the installation guide but the following error occurs :

-------- WWWW ------- G4Exception-START -------- WWWW -------

*** ExceptionHandler is not defined ***
*** G4Exception : UI0002
issued by : G4UIExecutive::G4UIExecutive()
Specified session type is not build in your system,
or no session type is specified.
A fallback session type is used.
*** This is just a warning message. ***
-------- WWWW ------- G4Exception-END -------- WWWW -------

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : PART70000
issued by : G4NuclideTable
G4ENSDFSTATEDATA environment variable must be set
*** Fatal Exception *** core dump ***

I saw on the forum that *** core dump *** probleme could comes from environnement variables, so I followed the postinstall tutorial to add them to Path but it changed nothing (I’ve also reboot computer).

notes : Im on windows10, cmake 3.15.0, visual studio 2017 so everything should work properly right ? I’ve also chosen to activate Qt and OpenGL and install and build apparently worked

Thank you for reading me and for helping me !

1 Like

You should set data directories from environmental variables, it will fix the data issue. The other point: qt interface is not completely compatible on windows. You can try another qt version or you can use Geant4 on windows without qt interface.

Thank you for your reply, but could you please tell me how to do it ?

you can do it as mentioned in installation guide,

Thank you for your kind attention.

In fact, I just did not correctly followed the instructions on this page, but I finally understood them and now all works just fine.

Sorry for wasting your time!

I’m getting this error while run exampleB1.

USER-no-MacBook-Air:B1_build user$ ./exampleB1
Available UI session types: [ Qt, GAG, tcsh, csh ]
Segmentation fault: 11

What can I do now? Please reply.

Hello, I am running into the same issue trying to install Geant 4 in Windows 10. Just as you post here I am using cmake 3.18.2, visual studio 2019 so everything should work properly right. Install and build apparently worked. I can also build example B1 with no problem. This issue appears when I run the executable generated by the example. I traced the issue to the post installation guide in this post, but I believe I did everything correctly in the post install guide for windows (Im probably wrong if not it would be working). Could you please help me as we seem to have the same issue and I saw that you were able to solve it with the post install guide? Thank you