Problem using OpenGL

Hello! I am running Geant4 10.5_p1 with Windows 10, Visual Studio 2019, and CMake 3.14.3. I’m trying to use OpenGL with example B1. I’ve set GEANT4_USE_OPENGL_WIN32 to on, but when I enter /vis/open OGL 600x600-0+0 or /vis/sceneHandler/create OGL I get this error message:
parameter value (OGL) is not listed in the candidate List.
Candidates are: ATree DAWNFILE HepRepFile HepRepXML RayTracer VRML1FILE VRML2FILE gMocrenFile
What should I try next? Thanks.

Did you set GEANT4_USE_OPENGL_WIN32 in the CMake configuration when building Geant4 itself? It only has an effect there, not when building an example. The example should, unless you’ve modified the CMakeLists.txt file, enable all vis/ui drivers that are available.

Ok, I tried setting GEANT4_USE_OPENGL_WIN32 to on again while building Geant4, then I built example B1 again, and that worked!
Thank you!

Hi everyone,
I am a new user in geant4, i build solution using visual studio 2017 and cmake 3.14.5 on windows 10 with following parameters


when i open the solution Geant4.sln in visual studio 2017 to install, I suffered the following errors shown in text file.
GEANT_install_error_list.txt (11.7 KB)

How to fix this problem? Thanks

Please start a new topic rather than on a totally unrelated and resolved thread.