Weird decay spectrum

Hi there,

I have been trying to simulate behavior of positrons emitted from Na-22 decay. In PhysicsList, i implemented PENELOPE and RadioactiveDecay. In stepping action I collect positrons, which have parent ID of Na-22. However, simulation appears to run correctly, there is phenomena I cannot explain/resolve. As you can see there is massive peak at beginning of e+ spectrum. This, as far as I know, has no physical reason. So I tried to set cuts as low as possible, I dumped energies to text file and evaluated them in different SW than root in order to determine error behavior of analysis manager, nothing worked. Can you please explain this to me and help me resolve it? Or is it a fact I simply have to accept and go on :smiley: ? Thank you for the response.


Cheers. Matus


how you score e+ in stepping action? Each e+ is scored only once? PreStep or PostStep energy is used?


Thank you for your quick response!

Here is the condition:

if(step->GetTrack()->GetDefinition() == G4Positron::Definition() && step->GetTrack()->GetCurrentStepNumber() == 1 && step->GetTrack()->GetParentID == 1){

 const G4Event* evt = G4RunManager::GetRunManager()->GetCurrentEvent();
 if(evt) fEventAction->eID1 = evt->GetEventID();

It should be scored only once, since number of primary particles = number of positrons in histogram. Second and third part of condition should ensure, it won’t be rewritten.


you are using PostStep energy. Please, try out PreStep kinetic energy.

Thank you Mr. Ivantchenko for your advice and time. Spectrum seems normal now. Sorry to bother you with this, I should have noticed it sooner.

Kind regards, Matus Saro